summary refs log tree commit diff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@cray.com>2018-10-02 13:53:13 -0500
committerEric Bavier <bavier@member.fsf.org>2018-10-02 22:34:39 -0500
commit68faa20e2d4511b43062f8279cc407aee735b275 (patch)
tree6fac0e63203f0af9440b191199743666f8097b62 /gnu/packages/patchutils.scm
parent000b540791f082b8a8398dc2ed51fd1526d8357d (diff)
downloadguix-68faa20e2d4511b43062f8279cc407aee735b275.tar.gz
quilt: Upgrade to 0.65.
* gnu/packages/patches/quilt-test-fix-regex.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/patchutils.scm (quilt)[version]: Upgrade to 0.65.
[source]: Use patch.
[arguments]: Adjust 'patch-tests' phase for new tests.  Re-enable "mail"
test.
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index a68e369912..0cf111ac47 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
@@ -92,7 +92,7 @@ listing the files modified by a patch.")
 (define-public quilt
   (package
     (name "quilt")
-    (version "0.61")
+    (version "0.65")
     (source
      (origin
       (method url-fetch)
@@ -100,7 +100,8 @@ listing the files modified by a patch.")
                           name "-" version ".tar.gz"))
       (sha256
        (base32
-        "1hwz58djkq9cv46sjwxbp2v5m8yjr41kd0nm1zm1xm6418khmv0y"))))
+        "06b816m2gz9jfif7k9v2hrm7fz76zjg5pavf7hd3ifybwn4cgjzn"))
+      (patches (search-patches "quilt-test-fix-regex.patch"))))
     (build-system gnu-build-system)
     (inputs `(("perl" ,perl)
               ("less" ,less)
@@ -116,8 +117,16 @@ listing the files modified by a patch.")
                  '("test/run"
                    "test/edit.test") 
                (("/bin/sh") (which "sh")))
-             ;; TODO: Run the mail tests once the mail feature can be supported.
-             (delete-file "test/mail.test")
+             (substitute* "test/create-delete.test"
+               ;; We'd rather use quilt's compat/getopt than declare a
+               ;; dependency on util-linux, but this test fails because of
+               ;; compat/getopt's handling of "---" in this test, so remove it
+               ;; for now.
+               ((" ---") ""))
+             (substitute* '("test/empty-files.test" "test/faildiff.test")
+               ;; compat/getopt seems not to handle splitting of short opts
+               ;; from its arguments.
+               (("-pab") "-p ab"))
              #t))
          (add-after 'install 'wrap-program
            ;; quilt's configure checks for the absolute path to the utilities it