summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2023-11-11 16:50:39 -0500
committerLudovic Courtès <ludo@gnu.org>2023-12-11 23:34:31 +0100
commit17213c1b20dd784bfe421813b1ce9995be48261f (patch)
treeb036acef505b9b40831809d0b3c0e37c537aed38 /gnu/packages/pdf.scm
parentd74faef4f7f451edcda13f3b5297217cc041e1c1 (diff)
downloadguix-17213c1b20dd784bfe421813b1ce9995be48261f.tar.gz
gnu: pdfarranger: Update to 1.10.1.
* gnu/packages/pdf.scm (pdfarranger): Update to 1.10.1.
[arguments]: Add set-home phase.

Change-Id: Id31925e7e34fc4b23abb73456bac8cd0012f1d6f
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index be9f13d7b6..874076effb 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1388,7 +1388,7 @@ manage or manipulate PDFs.")
 (define-public pdfarranger
   (package
     (name "pdfarranger")
-    (version "1.9.2")
+    (version "1.10.1")
     (source
      (origin
        (method git-fetch)
@@ -1397,7 +1397,7 @@ manage or manipulate PDFs.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1zj1fdaqih9d878yxy96ivgqyg4j31slvh2gqsyz2l2vj3s8z54x"))))
+        (base32 "0bi3yyns05yamml5jcnqvdaf7i19jg636wb1fj2mwlial9ww7zwp"))))
     (build-system python-build-system)
     (arguments
      (list
@@ -1409,7 +1409,10 @@ manage or manipulate PDFs.")
               (let ((program (string-append #$output "/bin/pdfarranger")))
                 (wrap-program program
                   `("GI_TYPELIB_PATH" ":" prefix
-                    (,(getenv "GI_TYPELIB_PATH"))))))))))
+                    (,(getenv "GI_TYPELIB_PATH")))))))
+          (add-before 'sanity-check 'set-home
+            (lambda _
+              (setenv "HOME" "/tmp"))))))
     (native-inputs
      (list intltool python-distutils-extra))
     (inputs