summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-04-28 22:05:27 +0200
committerAndreas Enge <andreas@enge.fr>2013-04-28 22:05:27 +0200
commit19cb51701266404e023eda5a50c026bccb0dc6a0 (patch)
tree27443f6551a40d7d8d4127b7a9b314584414ccdc /gnu/packages/pdf.scm
parent1f7c6a1f53d0a752af70de123f2ce9d138e0db0a (diff)
downloadguix-19cb51701266404e023eda5a50c026bccb0dc6a0.tar.gz
gnu: xpdf: Use gs-fonts to provide standard postscript fonts.
* gnu/packages/pdf (xpdf): Add path to gs-fonts in xpdfrc.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index b2f1ade143..820a879288 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -82,6 +82,7 @@
                      "1jnfzdqc54wa73lw28kjv0m7120mksb0zkcn81jdlvijyvc67kq2"))))
    (build-system gnu-build-system)
    (inputs `(("freetype" ,freetype)
+             ("gs-fonts" ,gs-fonts)
              ("lesstif" ,lesstif)
              ("libpaper" ,libpaper)
              ("libx11" ,libx11)
@@ -95,7 +96,21 @@
    (arguments
     `(#:tests? #f ; there is no check target
       #:patches (list (assoc-ref %build-inputs
-                                 "patch/constchar"))))
+                                 "patch/constchar"))
+      #:phases
+       (alist-replace
+        'install
+        (lambda* (#:key outputs inputs #:allow-other-keys #:rest args)
+         (let* ((install (assoc-ref %standard-phases 'install))
+                (out (assoc-ref outputs "out"))
+                (xpdfrc (string-append out "/etc/xpdfrc"))
+                (gs-fonts (assoc-ref inputs "gs-fonts")))
+               (apply install args)
+               (substitute* xpdfrc
+                (("/usr/local/share/ghostscript/fonts")
+                 (string-append gs-fonts "/share/fonts/type1/ghostscript"))
+                (("#fontFile") "fontFile"))))
+        %standard-phases)))
    (synopsis "Viewer for pdf files based on the Motif toolkit.")
    (description
     "Xpdf is a viewer for Portable Document Format (PDF) files")