summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-10 16:46:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-10 16:48:55 +0100
commit301804d67481a25ed81862796df50af88443603f (patch)
tree140ff2587dfd0c71db14c6ce11389cd4f14083c1 /gnu/packages/pdf.scm
parent78cd051eef9e25a6993478619d2bdb2db60565a6 (diff)
downloadguix-301804d67481a25ed81862796df50af88443603f.tar.gz
gnu: poppler: Build against openjpeg@2.
* gnu/packages/pdf.scm (poppler)[inputs]: Change OPENJPEG-1 to OPENJPEG.
[arguments]<#:phases>: Remove.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 84b9261885..c515715362 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -94,7 +94,7 @@
              ("libpng" ,libpng)
              ("libtiff" ,libtiff)
              ("lcms" ,lcms)
-             ("openjpeg-1" ,openjpeg-1) ; prefers openjpeg-1
+             ("openjpeg" ,openjpeg)
              ("zlib" ,zlib)
 
              ;; To build poppler-glib (as needed by Evince), we need Cairo and
@@ -114,16 +114,7 @@
         "--enable-zlib"
 
         ;; Saves 8 MiB of .a files.
-        "--disable-static")
-      #:phases
-      (modify-phases %standard-phases
-        (add-before 'configure 'setenv
-          (lambda _
-            (setenv "CPATH"
-                    (string-append (assoc-ref %build-inputs "openjpeg-1")
-                                   "/include/openjpeg-1.5"
-                                   ":" (or (getenv "CPATH") "")))
-            #t)))))
+        "--disable-static")))
    (synopsis "PDF rendering library")
    (description
     "Poppler is a PDF rendering library based on the xpdf-3.0 code base.")