summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2021-07-10 09:11:34 +0200
committerLeo Famulari <leo@famulari.name>2021-07-10 14:17:49 -0400
commit5c45ed059cfccd9fc333577403109fc4dffd1397 (patch)
tree7c481473ffdbe262aa808557deb456283eb07e6f /gnu/packages/pdf.scm
parent45fdb0350028c9c2ca57c40307563a0ab423b76a (diff)
downloadguix-5c45ed059cfccd9fc333577403109fc4dffd1397.tar.gz
gnu: qpdfview: Use qt-build-system.
This fixes compilation after the recent reorganization of qt-build-system. As
a side effect, specifying Qt plugins with environment variables now works.

* gnu/packages/pdf.scm (qpdfview)[build-system]: Use qt-build-system.
[arguments]: Drop #:modules and #:imported-modules, and the 'qt-wrap
phase. Specify that there are no tests.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 9298332940..4d1b8cddfe 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -839,7 +839,7 @@ program capable of converting PDF into other formats.")
        (sha256
         (base32 "0v1rl126hvblajnph2hkansgi0s8vjdc5yxrm4y3faa0lxzjwr6c"))
        (patches (search-patches "qpdfview-qt515-compat.patch"))))
-    (build-system gnu-build-system)
+    (build-system qt-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
@@ -850,22 +850,14 @@ program capable of converting PDF into other formats.")
        ("qtbase" ,qtbase-5)
        ("qtsvg" ,qtsvg)))
     (arguments
-     `(#:imported-modules ((guix build qt-build-system)
-                           (guix build cmake-build-system)
-                           ,@%gnu-build-system-modules)
-       #:modules ((guix build utils)
-                  (guix build gnu-build-system)
-                  ((guix build qt-build-system) #:prefix qt:))
+     `(#:tests? #f ; no tests
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
            (lambda _
              (substitute* "qpdfview.pri"
                (("/usr") (assoc-ref %outputs "out")))
-             (invoke "qmake" "qpdfview.pro")))
-         ;; Otherwise, the user interface will not display any icons.
-         (add-after 'install 'qt-wrap
-           (assoc-ref qt:%standard-phases 'qt-wrap)))))
+             (invoke "qmake" "qpdfview.pro"))))))
     (home-page "https://launchpad.net/qpdfview")
     (synopsis "Tabbed document viewer")
     (description "@command{qpdfview} is a document viewer for PDF, PS and DJVU