summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 13:18:19 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 21:58:44 +0100
commit5d8549328483978bf04dd2c710ef6a06614d4776 (patch)
treea78aa30b1cad46da683f79f32ec7d1935c3c2784 /gnu/packages/pdf.scm
parentf54d6bacbf46f5f25d3f7a5bea578879ee865be1 (diff)
downloadguix-5d8549328483978bf04dd2c710ef6a06614d4776.tar.gz
gnu: Remove python-setuptools and python2-setuptools from inputs (part 1b)
This patch contains the changes in all modules beside python.scm where
removing setuptools from the inputs could be achieved by removing complete
lines.

* gnu/packages/admin.scm (graphios, thefuck): Remove all [inputs],
  [native-inputs] and [propagated-inputs] where python-setuptools or
  python2-setuptools are the sole entries. Remove python-setuptools and
  python2-setuptools listed on a line by its own from [inputs],
  [native-inputs] and [propagated-inputs].
* gnu/packages/backup.scm (rdiff-backup): Likewise.
* gnu/packages/bioinformatics.scm (htseq, macs, python2-pbcore, rseqc,
  multiqc): Likewise.
* gnu/packages/django.scm (python-django, python2-django,
  python-django-simple-math-captcha, python2-django-simple-math-captcha):
  Likewise.
* gnu/packages/docker.scm (python-docker-py, docker-compose): Likewise.
* gnu/packages/game-development.scm (python-pygame): Likewise.
* gnu/packages/key-mon.scm (key-mon): Likewise.
* gnu/packages/mail.scm (khard): Likewise.
* gnu/packages/music.scm (beets, python2-pyechonest): Likewise.
* gnu/packages/openstack.scm (python-bandit, python2-bandit,
  python-debtcollector, python2-debtcollector,
  python-mox3, python2-mox3,
  python-os-client-config, python2-os-client-config,
  python-oslo.config, python2-oslo.config,
  python-oslo.context, python2-oslo.context,
  python-oslo.i18n, python2-oslo.i18n,
  python-oslo.serialization, python2-oslo.serialization,
  python-oslosphinx, python2-oslosphinx,
  python-oslotest, python2-oslotest,
  python-oslo.utils, python2-oslo.utils,
  python-swiftclient, python2-swiftclient): Likewise.
* gnu/packages/pdf.scm (pdfposter): Likewise.
* gnu/packages/tls.scm (python-acme, python2-acme): Likewise.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm2
1 files changed, 0 insertions, 2 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 9c6e9a967e..171f1990f7 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -874,8 +874,6 @@ python-pypdf2 instead.")
     (inputs
      ;; pdfposter 0.6.0 still uses the old pyPdf
      `(("python2-pypdf" ,python2-pypdf)))
-    (native-inputs
-     `(("python2-setuptools" ,python2-setuptools)))
     (home-page "https://pythonhosted.org/pdftools.pdfposter/")
     (synopsis "Scale and tile PDF images/pages to print on multiple pages")
     (description "@command{pdfposter} can be used to create a large poster by