summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-22 10:28:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-22 10:45:19 +0300
commit85c769709fdbb04f27a04fe494e6831e2397fe7b (patch)
treed4cd8266db631bc622a3c8d3d1253e06d6869547 /gnu/packages/pdf.scm
parent716f970e6d0dad95fc03f08e0c3ee115a1397e69 (diff)
downloadguix-85c769709fdbb04f27a04fe494e6831e2397fe7b.tar.gz
gnu: zathura: Remove input labels.
* gnu/packages/pdf.scm (zathura)[native-inputs]: Remove input labels.
[arguments]: Adjust custom 'start-xserver phase accordingly.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 998798a84a..d698450656 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -634,19 +634,20 @@ by using the poppler rendering engine.")
               (sha256
                (base32
                 "1c8vmfpghqlq5kdnq92bzzp2grym3x3kxxxqgs51178s4z7639lq"))))
-    (native-inputs `(("pkg-config" ,pkg-config)
-                     ("gettext" ,gettext-minimal)
-                     ("glib:bin" ,glib "bin")
+    (native-inputs
+     (list pkg-config
+           gettext-minimal
+           (list glib "bin")
 
-                     ;; For building documentation.
-                     ("python-sphinx" ,python-sphinx)
+           ;; For building documentation.
+           python-sphinx
 
-                     ;; For building icons.
-                     ("librsvg" ,(librsvg-for-system))
+           ;; For building icons.
+           (librsvg-for-system)
 
-                     ;; For tests.
-                     ("check" ,check)
-                     ("xorg-server" ,xorg-server-for-tests)))
+           ;; For tests.
+           check
+           xorg-server-for-tests))
     (inputs (list sqlite))
     ;; Listed in 'Requires.private' of 'zathura.pc'.
     (propagated-inputs (list cairo girara))
@@ -660,8 +661,7 @@ by using the poppler rendering engine.")
                   (add-before 'check 'start-xserver
                     ;; Tests require a running X server.
                     (lambda* (#:key inputs #:allow-other-keys)
-                      (let ((xorg-server (assoc-ref inputs "xorg-server"))
-                            (display ":1"))
+                      (let ((display ":1"))
                         (setenv "DISPLAY" display)
 
                         ;; On busy machines, tests may take longer than
@@ -670,8 +670,9 @@ by using the poppler rendering engine.")
 
                         ;; Don't fail due to missing '/etc/machine-id'.
                         (setenv "DBUS_FATAL_WARNINGS" "0")
-                        (zero? (system (string-append xorg-server "/bin/Xvfb "
-                                                      display " &")))))))))
+                        (zero? (system (string-append
+                                         (search-input-file inputs "/bin/Xvfb")
+                                         " " display " &")))))))))
     (home-page "https://pwmt.org/projects/zathura/")
     (synopsis "Lightweight keyboard-driven PDF viewer")
     (description "Zathura is a customizable document viewer.  It provides a