summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-28 13:02:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-28 13:02:28 +0300
commitc1ca85323d5246fc805a31e03b4164b8da08e930 (patch)
tree4167b0dfdba992c1f21d898c711d078ceba2cdc5 /gnu/packages/pdf.scm
parentbabab31fdd64d1f355c24b8f53d3aea3ff47fcf8 (diff)
downloadguix-c1ca85323d5246fc805a31e03b4164b8da08e930.tar.gz
gnu: mupdf: Update to 1.19.0.
* gnu/packages/pdf.scm (mupdf): Update to 1.19.0.
[source]: Remove patches. Add directory to be saved in snippet
* gnu/packages/patches/mupdf-CVE-2021-3407.patch,
gnu/packages/patches/mupdf-fix-linkage.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 704093e16c..ec5f2a4f9b 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -710,21 +710,20 @@ extracting content or merging files.")
 (define-public mupdf
   (package
     (name "mupdf")
-    (version "1.18.0")
+    (version "1.19.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://mupdf.com/downloads/archive/"
                            "mupdf-" version "-source.tar.xz"))
        (sha256
-        (base32 "16m5sksil22sshxy70xkslsb2qhvcqb1d95i9savnhds1xn4ybar"))
-       (patches (search-patches "mupdf-fix-linkage.patch"
-                                "mupdf-CVE-2021-3407.patch"))
+        (base32 "1i98xqgnzp168hnnhradl8658qsif06wlbvcglz0mmh8wi1rkwrq"))
        (modules '((guix build utils)))
        (snippet
         '(begin
            ;; Remove bundled software.
-           (let* ((keep (list "lcms2")) ; different from our lcms2 package
+           (let* ((keep (list "extract"
+                              "lcms2")) ; different from our lcms2 package
                   (from "thirdparty")
                   (kept (string-append from "~temp")))
              (mkdir-p kept)