summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-15 13:06:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-15 13:06:03 +0300
commitdc2cfc9bea6f79095fdf363362823c0eabb95022 (patch)
treeadd1da5a72b73198c0be7ea80e42d6b8838dc8c5 /gnu/packages/pdf.scm
parentcee779c80087f8eb0a164521a00fdb60bb0b05ca (diff)
downloadguix-dc2cfc9bea6f79095fdf363362823c0eabb95022.tar.gz
gnu: poppler: Fix cross-compiling.
* gnu/packages/pdf.scm (poppler)[native-inputs]: When cross-compiling
add pkg-config-for-build.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index d561f73dbd..378655a70f 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -341,10 +341,14 @@ please install the @code{flyer-composer-gui} package.")))
     ;; different solution to the circular dependency mentioned above.
     (list glib))
    (native-inputs
+    (append
       (list pkg-config
             `(,glib "bin") ; glib-mkenums, etc.
             gobject-introspection
-            python))
+            python)
+      (if (%current-target-system)
+        (list pkg-config-for-build)
+        '())))
    (arguments
     (list
      ;; The Poppler test suite needs to be downloaded separately and contains