summary refs log tree commit diff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:10:36 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:45:59 +0100
commit3840c515552207706aca8128066142d52bf64476 (patch)
treed4ed8c5731219e4b3e830d61756f03d445583849 /gnu/packages/perl-check.scm
parent709a9e9214901defe68dc9cc82ef045bafaa9dae (diff)
downloadguix-3840c515552207706aca8128066142d52bf64476.tar.gz
gnu: Add perl-test-version.
* gnu/packages/perl-check.scm (perl-test-version): New variable.
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 10583822f7..47e25083cd 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -1375,6 +1375,32 @@ check if a string is valid and not corrupt, whereas the characteristics tests
 will check that string has a given set of characteristics.")
     (license perl-license)))
 
+(define-public perl-test-version
+  (package
+    (name "perl-test-version")
+    (version "2.09")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/P/PL/PLICEASE/Test-Version-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1q1qradaf7r2rb3jhpv01wl8z3bxymkfqrl9gwdhxwx5jwldvqcw"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-exception" ,perl-test-exception)))
+    (propagated-inputs
+     `(("perl-file-find-rule-perl" ,perl-file-find-rule-perl)))
+    (home-page "https://metacpan.org/release/Test-Version")
+    (synopsis "Check versions in modules")
+    (description
+     "@code{Test::Version} checks to ensure that all modules have a version
+defined, and that the version is valid.")
+    (license artistic2.0)))
+
 (define-public perl-test-warn
   (package
     (name "perl-test-warn")