summary refs log tree commit diff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-13 22:14:18 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-13 22:57:04 +0100
commit78b2034b5bd879a86a1ab24db3f0da1bc2998055 (patch)
treee65cd9bde763857be73f865d0a80ccb9177586dd /gnu/packages/perl-check.scm
parent0d49a4bbe1df4b12abf1ca2710170b568e33c140 (diff)
downloadguix-78b2034b5bd879a86a1ab24db3f0da1bc2998055.tar.gz
gnu: perl-test2-suite: Correct name.
* gnu/packages/perl-check.scm (perl-test2-bundle-extended): Rename to…
(perl-test2-suite): …this.
[name]: Adjust accordingly.
(perl-test2-plugin-nowarnings)[propagated-inputs]: Use new name.
* gnu/packages/perl.scm (perl-params-validationcompiler)[native-inputs]:
Likewise.
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 9944c31305..2f6976e70f 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -66,9 +66,9 @@ implementation as used in cperl.  It does not store the mocked overrides
 lexically, just dynamically.")
     (license artistic2.0)))
 
-(define-public perl-test2-bundle-extended
+(define-public perl-test2-suite
   (package
-    (name "perl-test2-bundle-extended")
+    (name "perl-test2-suite")
     (version "0.000072")
     (source
       (origin
@@ -88,7 +88,7 @@ lexically, just dynamically.")
      `(("perl-importer" ,perl-importer)
        ("perl-term-table" ,perl-term-table)
        ("perl-sub-info" ,perl-sub-info)))
-    (home-page "https://metacpan.org/pod/Test2::Bundle::Extended")
+    (home-page "https://metacpan.org/pod/Test2-Suite")
     (synopsis "Full set of tools for Test2::Suite")
     (description "This package provides a rich set of tools, plugins, bundles,
 etc built upon the Test2 testing library.")
@@ -108,7 +108,7 @@ etc built upon the Test2 testing library.")
           "002qk6qsm0l6r2kaxywvc38w0yf0mlavgywq8li076pn6kcw3242"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-test2-bundle-extended" ,perl-test2-bundle-extended)))
+     `(("perl-test2-suite" ,perl-test2-suite)))
     (home-page "https://metacpan.org/release/Test2-Plugin-NoWarnings")
     (synopsis "Fail if tests warn")
     (description "Loading this plugin causes your tests to fail if there any