summary refs log tree commit diff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-22 08:50:53 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-04 21:07:07 -0400
commitd783ed7414096f59167428cb4df3f7aaf9e5922f (patch)
tree7cb7d61859daa3f2686b19b50f6df6efd07cd5ff /gnu/packages/perl-check.scm
parent70dcad2ba465910356d5b0150f52b613d499f2bc (diff)
downloadguix-d783ed7414096f59167428cb4df3f7aaf9e5922f.tar.gz
gnu: Add perl-test-portability-files.
* gnu/packages/perl-check.scm (perl-test-portability-files): New variable.
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index a761ebffcf..87f233a3aa 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -1157,6 +1157,31 @@ Pod::Simple to do the heavy lifting.")
 checks for pod coverage of all appropriate files.")
     (license artistic2.0)))
 
+(define-public perl-test-portability-files
+  (package
+    (name "perl-test-portability-files")
+    (version "0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/A/AB/ABRAXXA/"
+                           "Test-Portability-Files-" version ".tar.gz"))
+       (sha256
+        (base32 "05hs80gljkd6mhb8zvilyk3pjqxp5samgnymam5v9h9d94rb9r08"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-simple" ,perl-test-simple)))
+    (propagated-inputs
+     `(("perl-pathtools" ,perl-pathtools)))
+    (home-page "https://metacpan.org/dist/Test-Portability-Files")
+    (synopsis "Check file names portability")
+    (description "Test::Portability::Files module is used to check the
+portability across operating systems of the names of the files present in the
+distribution of a module.  The tests use the advices given in 'Files and
+Filesystems' in perlport.  The author of a distribution can select which tests
+to execute.")
+    (license perl-license)))
+
 (define-public perl-test-requires
   (package
     (name "perl-test-requires")