summary refs log tree commit diff
path: root/gnu/packages/perl-maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-06 09:35:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-06 10:12:13 +0100
commitcf32c21ecd3d9454e914db0c608d838c0790e1d1 (patch)
treeb3d331cca24d0a5c7881bbfbdff1796c25c98cc2 /gnu/packages/perl-maths.scm
parent764be13ee62eff202ee2dd711167d0bfa4d2ec3f (diff)
downloadguix-cf32c21ecd3d9454e914db0c608d838c0790e1d1.tar.gz
gnu: perl-math-cephes: Build reproducibly.
* gnu/packages/perl-maths.scm (perl-math-cephes)[source]: Sort result of
readdir.
Diffstat (limited to 'gnu/packages/perl-maths.scm')
-rw-r--r--gnu/packages/perl-maths.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/perl-maths.scm b/gnu/packages/perl-maths.scm
index 4f70c85fcf..b1110f94d2 100644
--- a/gnu/packages/perl-maths.scm
+++ b/gnu/packages/perl-maths.scm
@@ -35,7 +35,12 @@
                     version ".tar.gz"))
               (sha256
                (base32
-                "18c3xg53d1vv7hlj43601jj7ks119fm6ndpwpv94irr2905806jn"))))
+                "18c3xg53d1vv7hlj43601jj7ks119fm6ndpwpv94irr2905806jn"))
+              ;; For reproducibility
+              (modules '((guix build utils)))
+              (snippet
+               '(substitute* "libmd/Makefile.PL"
+                  (("readdir DIR") "sort readdir DIR")))))
     (build-system perl-build-system)
     (home-page "https://metacpan.org/release/Math-Cephes")
     (synopsis "Perl interface to the Cephes math library")