summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 20:56:11 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:30 +0300
commit017b014ce4a5defed12836886c4dfe2c5ae89d2d (patch)
tree630726d0a2d47373b66c98fb188120559cb27fde /gnu/packages/perl.scm
parent82e5e0dd52aac659a57bf07ae55e86cd531ea099 (diff)
downloadguix-017b014ce4a5defed12836886c4dfe2c5ae89d2d.tar.gz
gnu: Add perl-extutils-depends.
* gnu/packages/perl.scm (perl-extutils-depends): New public variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6a2ebbaa41..397a77b217 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3030,6 +3030,30 @@ and alternative installers with the `installler` option.  But it's written in
 only about 40% as many lines of code and with zero non-core dependencies.")
     (license (package-license perl))))
 
+(define-public perl-extutils-depends
+  (package
+    (name "perl-extutils-depends")
+    (version "0.405")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/X/XA/XAOC/ExtUtils-Depends-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0b4ab9qmcihsfs2ajhn5qzg7nhazr68v3r0zvb7076smswd41mla"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-number-delta"
+        ,perl-test-number-delta)))
+    (home-page "http://search.cpan.org/dist/ExtUtils-Depends/")
+    (synopsis "Easily build XS extensions that depend on XS extensions")
+    (description "ExtUtils::Depends builds XS extensions that depend on XS
+extensions")
+    (license (package-license perl))))
+
 (define-public perl-extutils-installpaths
   (package
     (name "perl-extutils-installpaths")