summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 11:41:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 12:19:45 +0200
commit10ed3525a42623178c444628187914998c034a05 (patch)
treedd3bdda7f906a73e4aeb658c26343352865dc1dd /gnu/packages/perl.scm
parent3329569bb4442a2ba25becafe01da90f58837b77 (diff)
downloadguix-10ed3525a42623178c444628187914998c034a05.tar.gz
gnu: Add perl-locale-maketext-lexicon.
* gnu/packages/perl.scm (perl-locale-maketext-lexicon): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1a0f2d4e95..86c9f0eba6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5567,6 +5567,32 @@ versa.")
      "Lexical::SealRequireHints prevents leakage of lexical hints")
     (license (package-license perl))))
 
+(define-public perl-locale-maketext-lexicon
+  (package
+    (name "perl-locale-maketext-lexicon")
+    (version "1.00")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DR/DRTECH/"
+                           "Locale-Maketext-Lexicon-" version ".tar.gz"))
+       (sha256
+        (base32 "0z6w3m6f3r29ljicdigsyvpa9w9j2m65l4gjxcw0wgwdll26ngxp"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-html-parser" ,perl-html-parser)
+       ("perl-lingua-en-sentence" ,perl-lingua-en-sentence)
+       ("perl-ppi" ,perl-ppi)
+       ("perl-template-toolkit" ,perl-template-toolkit)
+       ("perl-text-haml" ,perl-text-haml)
+       ("perl-yaml" ,perl-yaml)))
+    (home-page "https://metacpan.org/release/Locale-Maketext-Lexicon")
+    (synopsis "Use other catalog formats in Maketext")
+    (description
+     "This module provides lexicon-handling modules to read from other
+localization formats, such as Gettext, Msgcat, and so on.")
+    (license x11)))
+
 (define-public perl-log-any
   (package
     (name "perl-log-any")