summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-22 07:47:27 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-04 21:07:07 -0400
commit70dcad2ba465910356d5b0150f52b613d499f2bc (patch)
tree6698ad63c395e4f52552e9ff0a544a7f4f35e84d /gnu/packages/perl.scm
parentb24c1f5fbdfeaf0a76803b976d3477abf6989e61 (diff)
downloadguix-70dcad2ba465910356d5b0150f52b613d499f2bc.tar.gz
gnu: Add perl-term-ansicolor.
* gnu/packages/perl.scm (perl-term-ansicolor): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 91f077c6a4..c4d13e6ea3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9837,6 +9837,30 @@ situations, where you may need to upgrade to the full feature set in the
 future, or if you want the retain the familiarity of TT-style templates.")
     (license license:perl-license)))
 
+(define-public perl-term-ansicolor
+  (package
+    (name "perl-term-ansicolor")
+    (version "5.01")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RR/RRA/"
+                           "Term-ANSIColor-" version ".tar.gz"))
+       (sha256
+        (base32 "0zgj329kfrwcyqn491v04x65yjydwfc4845a71f8hypdrj3vv0b2"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-warn" ,perl-test-warn)))
+    (home-page "https://metacpan.org/dist/Term-ANSIColor")
+    (synopsis "Interface to the ANSI terminal escape sequences for color")
+    (description "Term::ANSIColor provides constants and simple functions for
+setting ANSI text attributes, most notably colors.  It can be used to set the
+current text attributes or to apply a set of attributes to a string and reset
+the current text attributes at the end of that string.  Eight-color,
+sixteen-color, 256-color, and true color (24-bit color) escape sequences are all
+supported.")
+    (license (package-license perl))))
+
 (define-public perl-term-encoding
   (package
     (name "perl-term-encoding")