summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-25 13:55:51 +0200
committerRoel Janssen <roel@gnu.org>2021-05-25 13:56:58 +0200
commit906cdbd4f93b346f4982617ad29e0ab396baac49 (patch)
tree9de49484f570a61f1d98f51f64ac9d7ec70e66ee /gnu/packages/perl.scm
parent414e41de64e0e8aeb380ff7c9e4b0a0420cf630b (diff)
downloadguix-906cdbd4f93b346f4982617ad29e0ab396baac49.tar.gz
gnu: Add perl-data-uuid.
* gnu/packages/perl.scm (perl-data-uuid): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0e18c73138..47d64e2f68 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2508,6 +2508,27 @@ generating unique ids.  These ids are coded with a Base62 system to make them
 short and handy (e.g. to use it as part of a URL).")
     (license (package-license perl))))
 
+(define-public perl-data-uuid
+  (package
+    (name "perl-data-uuid")
+    (version "1.226")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/R/RJ/RJBS/"
+                    "Data-UUID-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0lv4k4ibxwkw7zz9hw97s34za9nvjxb4kbmgmx5sj4fll3zmfg89"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Data-UUID")
+    (synopsis "Universally Unique Identifiers generator")
+    (description "@code{Data::UUID} provides a framework for generating
+Universally Unique Identifiers (UUIDs), also known as Globally Unique
+Identifiers (GUIDs).  A UUID is 128 bits long, and is guaranteed to be
+different from all other UUIDs/GUIDs generated until 3400 CE.")
+    (license (package-license perl))))
+
 (define-public perl-data-dump
   (package
     (name "perl-data-dump")