summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-03 21:25:40 +0100
committerMarius Bakke <marius@gnu.org>2022-02-03 23:39:47 +0100
commit9396fef40998ba6b580b2d6c5c7b774b7a6ccd1e (patch)
treeda59ec5201cabf578c9b1312dfefeb79ad6f2f5a /gnu/packages/perl.scm
parent16701a3c1dfefabe12770b064be293425964117f (diff)
downloadguix-9396fef40998ba6b580b2d6c5c7b774b7a6ccd1e.tar.gz
gnu: Add perl-date-range.
* gnu/packages/perl.scm (perl-date-range): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d2c9d0d24e..069c2c6e2e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -13,7 +13,7 @@
 ;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2016, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
-;;; Copyright © 2017, 2018, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2017, 2018, 2020-2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
 ;;; Copyright © 2017, 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
@@ -2958,6 +2958,28 @@ operations, such as comparing two times, determining a date a given amount of
 time from another, or parsing international times.")
     (license (package-license perl))))
 
+(define-public perl-date-range
+  (package
+    (name "perl-date-range")
+    (version "1.41")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/T/TM/TMTM/"
+                           "Date-Range-" version ".tar.gz"))
+       (sha256
+        (base32 "1fa8v75pbplmkb3ff6k0hd1m80p9xgksf54xhw1ha70h5d4rg65z"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     (list perl-date-simple))
+    (home-page "https://metacpan.org/dist/Date-Range")
+    (synopsis "Work with a range of dates")
+    (description
+     "@code{Date::Range} is a library to work with date ranges.  It can
+be used to determine whether a given date is in a particular range, or what
+the overlap between two ranges are.")
+    (license license:gpl2+)))
+
 (define-public perl-date-simple
   (package
     (name "perl-date-simple")