summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-07 15:47:05 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:51 -0500
commitf9671ab689b2743797e974a2260473543add7b3a (patch)
tree52c752966236d835fdab99115269223a30ee6d06 /gnu/packages/perl.scm
parentcc307bda85f410f14258723c65413daf95820e41 (diff)
downloadguix-f9671ab689b2743797e974a2260473543add7b3a.tar.gz
gnu: Add UNIVERSAL-can.
* gnu/packages/perl.scm (perl-universal-can): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f37f962385..ecda80a8d8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5443,6 +5443,25 @@ else.")
 common serialisation formats such as JSON or CBOR.")
     (license (package-license perl))))
 
+(define-public perl-universal-can
+  (package
+    (name "perl-universal-can")
+    (version "1.20140328")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CH/CHROMATIC/"
+                           "UNIVERSAL-can-" version ".tar.gz"))
+       (sha256
+        (base32
+         "03wr25zznbfn1g8zmmq3g6a6288xr30priwvm75y4vvqfkrajbaj"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/UNIVERSAL-can")
+    (synopsis "UNIVERSAL::can() reimplementation")
+    (description "This module attempts to work around people calling
+UNIVERSAL::can() as a function, which it is not.")
+    (license (package-license perl))))
+
 (define-public perl-variable-magic
   (package
     (name "perl-variable-magic")