summary refs log tree commit diff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 22:17:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:52 +0200
commitcdecb8d72dfd55d0179ed80706d6f2bb40e4d4d1 (patch)
tree968683940019a8b7c6285ffef8abfeff5061d46f /gnu/packages/perl6.scm
parentc2bc5b2bc05ec2f6c7d5fff3fe2fb12422755f20 (diff)
downloadguix-cdecb8d72dfd55d0179ed80706d6f2bb40e4d4d1.tar.gz
gnu: Add perl6-mime-base64.
* gnu/packages/perl6.scm (perl6-mime-base64): New variable.
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 883eb44203..f67533854f 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -478,6 +478,28 @@ as per the spec and where known the places that @quot{customary} attributes are
 used.")
     (license license:artistic2.0)))
 
+(define-public perl6-mime-base64
+  (package
+    (name "perl6-mime-base64")
+    (version "1.2.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/perl6/Perl6-MIME-Base64")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "0l67m8mvz3gxml425sd1ggfnhzh4lf754k7w8fngfr453s6lsza1"))))
+    (build-system rakudo-build-system)
+    (arguments '(#:with-zef? #f))
+    (home-page "https://github.com/perl6/Perl6-MIME-Base64")
+    (synopsis "Encoding and decoding Base64 ASCII strings")
+    (description "This Perl 6 module implements encoding and decoding to and
+from base64.")
+    (license license:artistic2.0)))
+
 (define-public perl6-oo-monitors
   (package
     (name "perl6-oo-monitors")