summary refs log tree commit diff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-08-06 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-08-13 02:00:00 +0200
commitefcdf66fe243d8ad16daf88a7df7f1d772ad5af3 (patch)
tree27c8ad1ec2d00675a10f755a4d36fc2c69c8eeef /gnu/packages/photo.scm
parentbaa7aa740f5e86a415cccdd35e82e7b043e05d2e (diff)
downloadguix-efcdf66fe243d8ad16daf88a7df7f1d772ad5af3.tar.gz
gnu: entangle: Fix build.
* gnu/packages/photo.scm (entangle)[arguments]:
Add a new 'build-with-meson-0.60 phase.
[native-inputs]: Add itstool.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 6c77d569c3..49f882095e 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -617,7 +617,7 @@ such as Batch image processing.")
 (define-public entangle
   (package
     (name "entangle")
-    (version "3.0")
+    (version "3.0")    ; delete the 'build-with-meson-0.60 phase when updating
     (source
      (origin
        (method git-fetch)
@@ -632,6 +632,12 @@ such as Batch image processing.")
      `(#:glib-or-gtk? #t
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'build-with-meson-0.60
+           ;; Work around ‘ERROR: Function does not take positional arguments.’.
+           (lambda _
+             (substitute* "src/meson.build"
+               (("^i18n\\.merge_file.*" match)
+                (string-append match "  data_dirs:")))))
          (add-after 'unpack 'skip-gtk-update-icon-cache
            ;; Don't create 'icon-theme.cache'.
            (lambda _
@@ -654,6 +660,7 @@ such as Batch image processing.")
        ("glib:bin" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("gtk-doc" ,gtk-doc)
+       ("itstool" ,itstool)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("xmllint" ,libxml2)))