summary refs log tree commit diff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-06-22 11:25:15 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-06-22 11:25:15 -0400
commitf25529b08e356f89ca7cecc44295085531a8faba (patch)
tree792b1c0e5b2db161063b91fbd1601feda65d1d92 /gnu/packages/photo.scm
parent37c2e94cec6cb8b5e0e93e7b6c712c3b187ca5db (diff)
downloadguix-f25529b08e356f89ca7cecc44295085531a8faba.tar.gz
gnu: darktable: Update to 4.4.0.
* gnu/packages/photo.scm (darktable): Update to 4.4.0.
[native-inputs]: Replace clang-11 and llvm-11 with clang and llvm,
respectively.  Darktable no longer builds with older versions.
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index c498703205..0a954c0e6f 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -459,7 +459,7 @@ photographic equipment.")
 (define-public darktable
   (package
     (name "darktable")
-    (version "4.2.1")
+    (version "4.4.0")
     (source
      (origin
        (method url-fetch)
@@ -467,7 +467,7 @@ photographic equipment.")
              "https://github.com/darktable-org/darktable/releases/"
              "download/release-" version "/darktable-" version ".tar.xz"))
        (sha256
-        (base32 "1b3vr6njwqfvnrx3qpbg5aqcbl1z8nxnxcgyyw0sd4a20z33jfk0"))))
+        (base32 "105hyc8rhc8md683h8mbvqxxc2f5w2bk3348n2c4jz6rmcsgr1w8"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -514,13 +514,13 @@ photographic equipment.")
                   (,(string-append #$(this-package-input "gtk+")
                                    "/share/glib-2.0/schemas")))))))))
     (native-inputs
-     (list clang-11
+     (list clang
            cmocka
            desktop-file-utils
            `(,glib "bin")
            gobject-introspection
            intltool
-           llvm-11                      ;should match the Clang version
+           llvm                         ;should match the Clang version
            opencl-headers
            perl
            pkg-config