summary refs log tree commit diff
path: root/gnu/packages/poedit.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/poedit.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
Diffstat (limited to 'gnu/packages/poedit.scm')
-rw-r--r--gnu/packages/poedit.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/poedit.scm b/gnu/packages/poedit.scm
index 3487636a3d..fd8ed06c83 100644
--- a/gnu/packages/poedit.scm
+++ b/gnu/packages/poedit.scm
@@ -60,19 +60,16 @@
                             (assoc-ref %build-inputs "boost")
                             "/lib"))))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("gettext-minimal" ,gettext-minimal)
-       ("pkg-config" ,pkg-config)))
+     (list autoconf automake gettext-minimal pkg-config))
     (inputs
-     `(("boost" ,boost)
-       ("enchant" ,enchant)
-       ("gtk+" ,gtk+)
-       ("gtkspell3" ,gtkspell3)
-       ("icu4c" ,icu4c)
-       ("lucene++" ,lucene++)
-       ("pugixml" ,pugixml)
-       ("wxwidgets" ,wxwidgets)))
+     (list boost
+           enchant
+           gtk+
+           gtkspell3
+           icu4c
+           lucene++
+           pugixml
+           wxwidgets))
     (home-page "https://poedit.net/")
     (synopsis "Gettext catalog editing tool")
     (description "Poedit is a GUI frontend to the GNU gettext utilities and