summary refs log tree commit diff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-09 15:16:03 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-11 00:32:42 +0200
commit69095cde82b2930ec9450f06aefcc7415524a615 (patch)
tree6698546ac17ce096401af53bf87d26908bfcb1e0 /gnu/packages/polkit.scm
parent32a87714f4507f853824d82d9c6ca10e1405c8eb (diff)
downloadguix-69095cde82b2930ec9450f06aefcc7415524a615.tar.gz
gnu: polkit: Incorporate security fix and remove replacement.
* gnu/packages/polkit.scm (polkit-mozjs)[replacement]: Remove.
[source]: Add "polkit-CVE-2021-4034.patch".
(polkit-mozjs/fixed): Remove.
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 1ae94be751..a544439fae 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -54,7 +54,6 @@
   (package
     (name "polkit")
     (version "0.120")
-    (replacement polkit-mozjs/fixed)
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -63,7 +62,8 @@
              (sha256
               (base32
                "00zfg9b9ivkcj2jcf5b92cpvvyljz8cmfwj86lkvy5rihnd5jypf"))
-             (patches (search-patches "polkit-configure-elogind.patch"))
+             (patches (search-patches "polkit-configure-elogind.patch"
+                                      "polkit-CVE-2021-4034.patch"))
              (modules '((guix build utils)))
              (snippet
               '(begin
@@ -147,16 +147,6 @@ making process with respect to granting access to privileged operations
 for unprivileged applications.")
     (license lgpl2.0+)))
 
-(define-public polkit-mozjs/fixed
-  (package
-    (inherit polkit-mozjs)
-    (version "0.121")
-    (source (origin
-              (inherit (package-source polkit-mozjs))
-              (patches (cons (search-patch "polkit-CVE-2021-4034.patch")
-                             (origin-patches
-                              (package-source polkit-mozjs))))))))
-
 ;;; Variant of polkit built with Duktape, a lighter JavaScript engine compared
 ;;; to mozjs.
 (define-public polkit-duktape