summary refs log tree commit diff
path: root/gnu/packages/potassco.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-25 10:44:44 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 10:55:06 +0100
commit77b36076537b5e04044b7096255ea073f4713322 (patch)
tree383ac28cf043304fe992c1be79b949681a8cb6ec /gnu/packages/potassco.scm
parent9f85c0cdb1f309e3f8e12bdbbba00e46a2453986 (diff)
downloadguix-77b36076537b5e04044b7096255ea073f4713322.tar.gz
gnu: python-clorm: Reindent with emacs.
* gnu/packages/potassco.scm (python-clorm): Reindent with emacs.
Diffstat (limited to 'gnu/packages/potassco.scm')
-rw-r--r--gnu/packages/potassco.scm58
1 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index afc4c4d513..0ec6253099 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -406,38 +406,38 @@ directly from the python command line.")))
 
 (define-public python-clorm
   (package
-   (name "python-clorm")
-   (version "1.4.1")
-   (source (origin
-            (method git-fetch)
-            (uri (git-reference
-                  (url "https://github.com/potassco/clorm")
-                  (commit (string-append "v" version))))
-            (file-name (git-file-name name version))
-            (sha256
-             (base32
-              "0jx99y71mrgdicn1da5dwz5nzgvvpabrikff783sg4shbv2cf0b5"))))
-   (build-system pyproject-build-system)
-   (arguments
-    (list #:phases
-          #~(modify-phases %standard-phases
-              (add-before 'check 'fix-breaking-tests
-                (lambda _
-                  ;; noclingo tests rely on this being set
-                  (setenv "CLORM_NOCLINGO" "1")
-                  (delete-file "tests/test_mypy_query.py")
-                  (substitute* "tests/test_clingo.py"
-                    (("self\\.assertTrue\\(os_called\\)" all)
-                     (string-append "# " all))))))))
-   (propagated-inputs (list python-clingo))
-   (native-inputs (list python-typing-extensions))
-   (home-page "https://potassco.org")
-   (synopsis "Object relational mapping to clingo")
-   (description "@acronym{Clorm, Clingo ORM} provides an @acronym{ORM,
+    (name "python-clorm")
+    (version "1.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/potassco/clorm")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0jx99y71mrgdicn1da5dwz5nzgvvpabrikff783sg4shbv2cf0b5"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'fix-breaking-tests
+                 (lambda _
+                   ;; noclingo tests rely on this being set
+                   (setenv "CLORM_NOCLINGO" "1")
+                   (delete-file "tests/test_mypy_query.py")
+                   (substitute* "tests/test_clingo.py"
+                     (("self\\.assertTrue\\(os_called\\)" all)
+                      (string-append "# " all))))))))
+    (propagated-inputs (list python-clingo))
+    (native-inputs (list python-typing-extensions))
+    (home-page "https://potassco.org")
+    (synopsis "Object relational mapping to clingo")
+    (description "@acronym{Clorm, Clingo ORM} provides an @acronym{ORM,
 Object Relational Mapping} interface to the @acronym{ASP, answer set
 programming} solver clingo.  Its goal is to make integration of clingo
 into Python programs easier.")
-   (license license:expat)))
+    (license license:expat)))
 
 (define-public python-telingo
   (package