summary refs log tree commit diff
path: root/gnu/packages/potassco.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-23 10:23:58 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-30 09:08:05 +0100
commitc34c3b1c2b1006ebeede016cca578d5f571fc7a8 (patch)
tree7139bca3a7060e334e2100dae97b6bf8b4e334ec /gnu/packages/potassco.scm
parent9408fa3754a6a445fb54cddb03368b6685a24d5a (diff)
downloadguix-c34c3b1c2b1006ebeede016cca578d5f571fc7a8.tar.gz
gnu: Add plasp.
* gnu/packages/patches/plasp-fix-normalization.patch: New file.
* gnu/packages/patches/plasp-include-iostream.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register them here.
* gnu/packages/potassoc.scm (plasp): New variable.

Change-Id: I0d8d64153b180a7d1d8d81888f843458efdf5e51
Diffstat (limited to 'gnu/packages/potassco.scm')
-rw-r--r--gnu/packages/potassco.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 887c220ccf..884da3c99f 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -243,6 +243,38 @@ satisfiability checking (SAT).")
 over difference logic.")
     (license license:expat)))
 
+(define-public plasp
+  (package
+    (name "plasp")
+    (version "3.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/potassco/plasp")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "123v1bjzh7yjwgcc5k55rkfz0lfl8ish5p3z8x3pn8k1svd50xal"))
+              (patches (search-patches
+                        "plasp-fix-normalization.patch"
+                        "plasp-include-iostream.patch"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f        ; No ‘test’ target
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (copy-recursively "bin"
+                                     (string-append (assoc-ref outputs "out")
+                                                    "/bin")))))))
+    (inputs (list cxxopts mapbox-variant))
+    (home-page "https://potassco.org/")
+    (synopsis "ASP planning tools for PDDL")
+    (description "@command{plasp} is a tool collection for planning in
+answer set programming.  It supports a subset of PDDL 3.1 and SAS 3.")
+    (license license:expat)))
+
 (define-public emacs-pasp-mode
   (let ((commit "59385eb0e8ebcfc8c11dd811fb145d4b0fa3cc92")
         (revision "1"))