summary refs log tree commit diff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:27:04 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:37:04 -0400
commit530cf34edbd5173e3973856600321e70815cc718 (patch)
treea2c2ae3f285a634cb8630109a3332586248b485f /gnu/packages/pretty-print.scm
parent7d3bb28a6fb552676f3ee373515739de205c3b52 (diff)
downloadguix-530cf34edbd5173e3973856600321e70815cc718.tar.gz
gnu: source-highlight: Inline skip-doc-directory phase.
* gnu/packages/pretty-print.scm (source-highlight) [source]: Fix indentation.
[arguments]: Inline skip-doc-directory phase.
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm61
1 files changed, 28 insertions, 33 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 58efb3237b..5e4d16e24a 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2022 Zhu Zihao  <all_but_last@163.com>
-;;; Copyright © 2022 Maxim Cournoyer  <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2023 Maxim Cournoyer  <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -275,13 +275,13 @@ a fast alternative to @code{IOStreams}.")
     (version "3.1.9")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/src-highlite/source-highlight-"
-                          version ".tar.gz"))
-      (patches (search-patches "source-highlight-gcc-compat.patch"))
-      (sha256
-       (base32
-        "148w47k3zswbxvhg83z38ifi85f9dqcpg7icvvw1cm6bg21x4zrs"))))
+       (method url-fetch)
+       (uri (string-append "mirror://gnu/src-highlite/source-highlight-"
+                           version ".tar.gz"))
+       (patches (search-patches "source-highlight-gcc-compat.patch"))
+       (sha256
+        (base32
+         "148w47k3zswbxvhg83z38ifi85f9dqcpg7icvvw1cm6bg21x4zrs"))))
     (build-system gnu-build-system)
     ;; The ctags that comes with emacs does not support the --excmd options,
     ;; so can't be used
@@ -292,38 +292,33 @@ a fast alternative to @code{IOStreams}.")
     (arguments
      (list #:configure-flags
            #~(list (string-append "--with-boost=" (assoc-ref %build-inputs "boost")))
-           #:parallel-tests? #f ;There appear to be race conditions
+           #:parallel-tests? #f         ;There appear to be race conditions
            #:phases
            #~(modify-phases %standard-phases
                (add-before 'build 'rename-lesspipe-to-lesspipe.sh.in
                  (lambda _
                    (substitute* "src/src-hilite-lesspipe.sh.in"
                      (("lesspipe") "lesspipe.sh"))))
-           #$@(if (%current-target-system)
-                  ;; 'doc/Makefile.am' tries to run stuff even when
-                  ;; cross-compiling.  Explicitly skip it.
-                  ;; XXX: Inline this on next rebuild cycle.
-                  #~((add-before 'build 'skip-doc-directory
-                       (lambda _
-                         (substitute* "Makefile"
-                           (("^SUBDIRS = (.*) doc(.*)$" _ before after)
-                            (string-append "SUBDIRS = " before
-                                           " " after "\n"))))))
-                  '())
+               (add-before 'build 'skip-doc-directory
+                 (lambda _
+                   (substitute* "Makefile"
+                     (("^SUBDIRS = (.*) doc(.*)$" _ before after)
+                      (string-append "SUBDIRS = " before
+                                     " " after "\n")))))
                (add-before 'check 'patch-test-files
-                  (lambda _
-                    ;; Unpatch shebangs in test input so that source-highlight
-                    ;; is still able to infer input language
-                    (substitute* '("tests/test.sh"
-                                   "tests/test2.sh"
-                                   "tests/test.tcl")
-                      (((string-append "#! *" (which "sh"))) "#!/bin/sh"))
-                    ;; Initial patching unrecoverably removes whitespace, so
-                    ;; remove it also in the comparison output.
-                    (substitute* '("tests/test.sh.html"
-                                   "tests/test2.sh.html"
-                                   "tests/test.tcl.html")
-                      (("#! */bin/sh") "#!/bin/sh")))))))
+                 (lambda _
+                   ;; Unpatch shebangs in test input so that source-highlight
+                   ;; is still able to infer input language
+                   (substitute* '("tests/test.sh"
+                                  "tests/test2.sh"
+                                  "tests/test.tcl")
+                     (((string-append "#! *" (which "sh"))) "#!/bin/sh"))
+                   ;; Initial patching unrecoverably removes whitespace, so
+                   ;; remove it also in the comparison output.
+                   (substitute* '("tests/test.sh.html"
+                                  "tests/test2.sh.html"
+                                  "tests/test.tcl.html")
+                     (("#! */bin/sh") "#!/bin/sh")))))))
     (home-page "https://www.gnu.org/software/src-highlite/")
     (synopsis "Produce a document with syntax highlighting from a source file")
     (description