summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-17 15:02:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-17 22:10:57 -0400
commit27a4bfbd07022ebabc352a419c7588fcfc881d88 (patch)
treef421fdddc7d8558713ee5e849accc6db961d61c3 /gnu/packages/python-check.scm
parent774a6fb12c884766856c86c00adaa8f2a1d42508 (diff)
downloadguix-27a4bfbd07022ebabc352a419c7588fcfc881d88.tar.gz
gnu: python-pytest-trio: Update to 0.8.0.
* gnu/packages/python-check.scm (python-pytest-trio): Update to 0.8.0.
[arguments]: New relax-requirements phase.  Delete extraneous
add-installed-pythonpath call.  Disable two new tests.

Reported-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm33
1 files changed, 21 insertions, 12 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1046602800..9ce093697d 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1086,33 +1086,42 @@ simpler.")
 (define-public python-pytest-trio
   (package
     (name "python-pytest-trio")
-    (version "0.7.0")
+    (version "0.8.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest-trio" version))
        (sha256
-        (base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
+        (base32 "0bmmdyjqj5v4a637i4rzm55crv6v3nj268as6x9nr7m76rixnqw3"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'relax-requirements
+           (lambda _
+             (substitute* "setup.py"
+               (("pytest >= 7.2.0")
+                "pytest"))))
          (replace 'check
            (lambda* (#:key tests? inputs outputs #:allow-other-keys)
              (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "pytest" "-W" "error" "-ra" "-v" "--pyargs"
-                       "pytest_trio" "--verbose" "--cov" "-k"
-                       (string-append
-                         ;; Needs network
-                         "not test_async_yield_fixture_with_nursery"
-                         " and not test_try"
-                         ;; No keyboard interrupt in our build environment.
-                         " and not test_actual_test"))))))))
+               (invoke
+                "pytest" "-W" "error" "-ra" "-v" "--pyargs"
+                "pytest_trio" "--verbose" "--cov" "-k"
+                (string-append
+                 ;; These tests require network.
+                 "not test_async_yield_fixture_with_nursery "
+                 "and not test_try "
+                 ;; No keyboard interrupt in our build environment.
+                 "and not test_actual_test "
+                 ;; These tests fail due to unclean teardown (see:
+                 ;; https://github.com/python-trio/pytest-trio/issues/122).
+                 "and not crashed_teardown "
+                 "and not test_error_collection "))))))))
     (native-inputs
      (list python-hypothesis python-pytest python-pytest-cov))
     (propagated-inputs
-      (list python-async-generator python-outcome python-pytest python-trio))
+     (list python-async-generator python-outcome python-pytest python-trio))
     (home-page "https://github.com/python-trio/pytest-trio")
     (synopsis "Pytest plugin for trio")
     (description