summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorVincent Prat <vprat@deeplinks.com>2023-06-26 11:44:47 +0200
committerChristopher Baines <mail@cbaines.net>2023-09-15 11:11:22 +0100
commiteeeaf13984b96ca8856532559d5ab755c560e42c (patch)
tree54ce849aff000658c89bc2d0c5c3c7d843cb3217 /gnu/packages/python-check.scm
parent9c9d6c3dab0a3c83ca30664d0461807d0289579b (diff)
downloadguix-eeeaf13984b96ca8856532559d5ab755c560e42c.tar.gz
gnu: python-mypy: Update to 1.4.1.
* gnu/packages/python-check.scm (python-mypy): Update to 1.4.1.
[origin]: Switch to PyPI.
[arguments]: Don't skip the testImports test.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm23
1 files changed, 5 insertions, 18 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 87e15b4560..3a718954c5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1834,24 +1834,14 @@ supported by the MyPy typechecker.")
 (define-public python-mypy
   (package
     (name "python-mypy")
-    (version "0.971")
+    (version "1.4.1")
     (source
      (origin
-       ;; Because of https://github.com/python/mypy/issues/9584, the
-       ;; mypyc/analysis directory is missing in the PyPI archive, leading to
-       ;; test failures.
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/python/mypy")
-             (commit (string-append "v" version))
-             ;; Fetch git submodules otherwise typeshed is not fetched.
-             ;; Typeshed is a collection of Python sources type annotation
-             ;; (data) files.
-             (recursive? #t)))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       (uri (pypi-uri "mypy" version))
        (sha256
         (base32
-         "0i8swdynms1wpiprgqn24za6mx8rlgxr2jash3cb5xi8jyf58n97"))))
+         "06svfmqbnb45pydy8lcrr12wqhhla5dl888w0g4f3wm1ismxkg4v"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1859,10 +1849,7 @@ supported by the MyPy typechecker.")
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest" "-vv" "mypyc"
-                       ;; XXX: This test gets an unexpected DeprecationWarning
-                       ;; from recent versions of setuptools.  Ignore for now.
-                       "-k" "not testImports")))))))
+               (invoke "pytest" "mypyc")))))))
     (native-inputs
      (list python-attrs
            python-lxml