summary refs log tree commit diff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-04-23 00:14:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-05-11 11:54:41 +0200
commitc158d47627a868a6a8b1f20630b01296fbad0a65 (patch)
treee012e5dc87df45f7d68c9c09870661616307884e /gnu/packages/python-crypto.scm
parentcef6dc646eaacbfd5800b134f426ccc41419d1b8 (diff)
downloadguix-c158d47627a868a6a8b1f20630b01296fbad0a65.tar.gz
gnu: Add python-pylibscrypt.
* gnu/packages/python-crypto.scm (python-pylibscrypt): New variable.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 1f5da022f0..b19364a843 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -841,3 +841,26 @@ through the Engine interface.")
 
 (define-public python2-m2crypto
   (package-with-python2 python-m2crypto))
+
+(define-public python-pylibscrypt
+  (package
+    (name "python-pylibscrypt")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pylibscrypt" version))
+       (sha256
+        (base32
+         "1b3rgzl6dbzs08vhv41b6y4n5189wv7lr27acxn104hs45745abs"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;FIXME: unable to find libraries
+    (inputs
+     `(("openssl" ,openssl)))
+    (home-page "https://github.com/jvarho/pylibscrypt")
+    (synopsis "Scrypt for Python")
+    (description "There are a lot of different scrypt modules for Python, but
+none of them have everything that I'd like, so here's one more.  It uses
+hashlib.scrypt on Python 3.6 and OpenSSL 1.1.")
+    (license license:isc)))