summary refs log tree commit diff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-23 23:40:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-23 23:51:48 +0000
commit5a616cc14b25d173680aa2f4787b996b68f899e0 (patch)
treef7b9c18a8ac1707fa2d40706b0d435e064e2a346 /gnu/packages/python-science.scm
parente71abbc6438f2b25f0d41221fadf695dfe094689 (diff)
downloadguix-5a616cc14b25d173680aa2f4787b996b68f899e0.tar.gz
gnu: python-pynetdicom: Simplify package style.
* gnu/package/python-science.scm (python-pynetdicom)[build-system]: Swap
to pyproject-build-system.
[description]: Simplify wording, indent.

Change-Id: If4e80d06edb0080685d0695f30abc2f9db669f45
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 44d0157665..a49562643b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2400,35 +2400,33 @@ NeuroML2 models.")
               (sha256
                (base32
                 "0farmgviaarb3f4xn751card3v0lza57vwgl5azxxq65p7li44i3"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     (list  #:phases #~(modify-phases %standard-phases
-                         (replace 'check
-                           (lambda* (#:key tests? #:allow-other-keys)
-                             (when tests?
-                               (invoke "pytest" "-vv" "-k"
-                                       ;; network tests, 2977/3283 pass
-                                       (string-append
-                                        " not TestFindSCP"
-                                        " and not TestQRGetServiceClass"
-                                        " and not TestQRMoveServiceClass"
-                                        " and not TestStoreSCP"
-                                        " and not test_ae.py"
-                                        " and not test_echoscp.py"
-                                        " and not test_qrscp_echo.py"
-                                        " and not test_storescp.py"
-                                        " and not test_pr_level_patient"
-                                        " and not test_pr_level_series"
-                                        " and not test_scp_cancelled"))))))))
+     (list
+      #:test-flags
+      ;; Tests takes about 10-15min to complete.
+      ;; Skip tests that require networking.
+      #~(list "-k" (string-append
+                    " not TestFindSCP"
+                    " and not TestQRGetServiceClass"
+                    " and not TestQRMoveServiceClass"
+                    " and not TestStoreSCP"
+                    " and not test_ae.py"
+                    " and not test_echoscp.py"
+                    " and not test_qrscp_echo.py"
+                    " and not test_storescp.py"
+                    " and not test_pr_level_patient"
+                    " and not test_pr_level_series"
+                    " and not test_scp_cancelled"))))
     (native-inputs (list python-pyfakefs python-pytest))
     (propagated-inputs (list python-pydicom python-sqlalchemy))
     (home-page "https://github.com/pydicom/pynetdicom")
     (synopsis "Python implementation of the DICOM networking protocol")
     (description
      "@code{pynetdicom} is a Python package that implements the DICOM
-networking protocol.  Working with @code{pydicom}, it allows the easy creation
-of DICOM @acronym{SCUs,Service Class Users} and
-@acronym{SCPs,Service Class Providers}.")
+networking protocol.  It allows the easy creation of DICOM
+@acronym{SCUs,Service Class Users} and @acronym{SCPs,Service Class
+Providers}.")
     (license license:expat)))
 
 (define-public python-libneuroml