summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-21 22:24:21 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-21 23:01:15 +0100
commit248199863cbdc3e13d5aa62fad6fe1c6a027b149 (patch)
treeb948b93920abc14e431643a94f1025f869697623 /gnu/packages/python-web.scm
parentb1fd9531149b94a7e7cdabc67b08ea6a47b03d3d (diff)
downloadguix-248199863cbdc3e13d5aa62fad6fe1c6a027b149.tar.gz
gnu: python-werkzeug: Reintroduce 1.0.1.
* gnu/packages/python-web.scm (python-werkzeug-1.0): New variable.
* gnu/packages/patches/python-werkzeug-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f34e352612..cadfa05e3a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4088,6 +4088,31 @@ uploads, a powerful URL routing system and a bunch of community-contributed
 addon modules.")
     (license license:x11)))
 
+(define-public python-werkzeug-1.0
+  (package
+    (inherit python-werkzeug)
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "Werkzeug" version))
+              (sha256
+               (base32
+                "0z74sa1xw5h20yin9faj0vvdbq713cgbj84klc72jr9nmpjv303c"))
+              (patches (search-patches "python-werkzeug-tests.patch"))))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'check)
+         (add-after 'install 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (invoke "python" "-m" "pytest"))))))
+    (propagated-inputs
+     `(("python-requests" ,python-requests)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-timeout" ,python-pytest-timeout)))))
+
 (define-public python-bottle
   (package
     (name "python-bottle")