summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-08-25 12:51:45 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-08-25 12:53:23 -0400
commit375a1a0558d77eddb06c7483e240b7c2f95e9695 (patch)
tree7f714390d48cd9c2a13885256915129a80d8bb1f /gnu/packages/python-web.scm
parent4fefbd4f147bc1174792dc2473c79c784de42065 (diff)
downloadguix-375a1a0558d77eddb06c7483e240b7c2f95e9695.tar.gz
gnu: python-canvasapi: Update to 3.2.0.
* gnu/packages/python-web.scm (python-canvasapi): Update to 3.2.0.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Add python-arrow.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 17c9563cfd..e491108188 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5008,7 +5008,7 @@ for URL parsing and changing.")
 (define-public python-canvasapi
   (package
     (name "python-canvasapi")
-    (version "2.2.0")
+    (version "3.2.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -5017,10 +5017,10 @@ for URL parsing and changing.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0i13wrq2czcaz3h98pvnsl237104v611y9636jf32b1nn76sbp0p"))))
-    (build-system python-build-system)
+                "1vbd3ndhmxi8scxgxs6sc7r0rdaliqd80384n06nyb3haqz25inm"))))
+    (build-system pyproject-build-system)
     (propagated-inputs (list python-pytz python-requests))
-    (native-inputs (list python-requests-mock))
+    (native-inputs (list python-arrow python-requests-mock))
     (home-page "https://github.com/ucfopen/canvasapi")
     (synopsis "API wrapper for the Canvas LMS")
     (description