summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-13 12:26:42 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-15 22:43:35 +0000
commit68763a00a30decdf04c05fcfe62e6d538b1a0bcf (patch)
treef72792efd07f3d5f563bd067db90bf2916d94900 /gnu/packages/python-web.scm
parent287dee537bf719f3543f932eb8f3610cac630374 (diff)
downloadguix-68763a00a30decdf04c05fcfe62e6d538b1a0bcf.tar.gz
gnu: hypercorn: Adjust inputs.
* gnu/packages/python-web.scm (hypercorn)[propagated-inputs]: Add
python-exceptiongroup and python-tomli. Remove python-toml and
python-typing-extensions.
[native-inputs]: Remove python-mock.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 418100c084..27fa183465 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2392,15 +2392,14 @@ RFC6455, regardless of your programming paradigm.")
     (build-system pyproject-build-system)
     ;; Propagate because Hypercorn also exposes functionality over a module.
     (propagated-inputs
-     (list python-h11
+     (list python-exceptiongroup
+           python-h11
            python-h2
            python-priority
-           python-toml
-           python-typing-extensions
+           python-tomli
            python-wsproto))
     (native-inputs
      (list python-hypothesis
-           python-mock
            python-poetry-core
            python-pytest
            python-pytest-asyncio