summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 11:15:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 11:44:21 +0200
commit78280e2e4a749a980886b71a5ac911193c370267 (patch)
tree93724e5884c0d3abd3cb41f9715a0b3f700b3df2 /gnu/packages/python-web.scm
parent04ea577b75adaf4d3110f2909e14eefb5e75cdf7 (diff)
downloadguix-78280e2e4a749a980886b71a5ac911193c370267.tar.gz
gnu: Add python-azure-common.
* gnu/packages/python-web.scm (python-azure-common): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ed047a7faa..5c03ec1544 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6627,6 +6627,25 @@ AutoRest-generated Python clients.")
 communicate with Microsoft Azure Storage services.")
     (license license:expat)))
 
+(define-public python-azure-common
+  (package
+    (name "python-azure-common")
+    (version "1.1.28")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "azure-common" version ".zip"))
+       (sha256
+        (base32 "18q4cy1xl2zly3rk7a1sc14w932x59r8c9j4d8dnlsz32hrcvh2a"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-azure-nspkg))
+    (native-inputs (list unzip))
+    (home-page "https://github.com/Azure/azure-sdk-for-python")
+    (synopsis "Microsoft Azure Client library for Python")
+    (description "This package provides the Microsoft Azure Client library for
+Python.")
+    (license license:expat)))
+
 (define-public python-w3lib
   (package
     (name "python-w3lib")