summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 14:11:59 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:37 +0100
commita1e9c929fa7e0b8b79f86c32830dad8ca3263b85 (patch)
treeccbfb97e484e4926c76ef93a7cc955825b529c13 /gnu/packages/python-web.scm
parentce4b7a44366b0d40699c082fbfa8d985681187c7 (diff)
downloadguix-a1e9c929fa7e0b8b79f86c32830dad8ca3263b85.tar.gz
gnu: python-zope-schema: Update to 5.0.1.
* gnu/packages/python-web.scm (python-zope-schema): Update to 5.0.1.
[propagated-inputs]: Remove PYTHON-ZOPE-EXCEPTIONS.
[native-inputs]: Remove PYTHON-NOSE and PYTHON-COVERAGE.  Add
PYTHON-ZOPE-TESTRUNNER and PYTHON-ZOPE-I18NMESSAGEID.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 848d5856b5..82185cd81f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1118,25 +1118,24 @@ internationalized messages within program source text.")
 (define-public python-zope-schema
   (package
     (name "python-zope-schema")
-    (version "4.4.2")
+    (version "5.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "zope.schema" version))
        (sha256
         (base32
-         "1p943jdxb587dh7php4vx04qvn7b2877hr4qs5zyckvp5afhhank"))))
+         "0q93j0x52a42khw12al90jw2bk0wly3jwghql3a25zpwwxvn24ya"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f)) ; FIXME: Tests can't find zope.event.
     (propagated-inputs
      `(("python-zope-event" ,python-zope-event)
-       ("python-zope-exceptions" ,python-zope-exceptions)
        ("python-zope-interface" ,python-zope-interface)))
     (native-inputs
-     `(("python-zope-testing" ,python-zope-testing)
-       ("python-coverage" ,python-coverage)
-       ("python-nose" ,python-nose)))
+     `(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
+       ("python-zope-testing" ,python-zope-testing)
+       ("python-zope-testrunner" ,python-zope-testrunner)))
     (home-page "https://pypi.org/project/zope.schema/")
     (synopsis "Zope data schemas")
     (description "Zope.scheme provides extensions to zope.interface for