summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-08 23:12:03 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:17 +0800
commita76ccdddaf70e0734b268f88cf7aa1dc6937a3e5 (patch)
tree674b0a4302795948478b90f1bb6f4d5d109d0161 /gnu/packages/python-web.scm
parentee7c9d254117fa470686210ad2ef5e7f1ba4fefc (diff)
downloadguix-a76ccdddaf70e0734b268f88cf7aa1dc6937a3e5.tar.gz
gnu: Add python-jwcrypto.
* gnu/packages/python-web.scm (python-jwcrypto): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 12f0ce6208..e1c5412a93 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2017, 2019-2022 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2016, 2017, 2019-2023 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017, 2021 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016, 2017, 2020 Julien Lepiller <julien@lepiller.eu>
@@ -1250,6 +1250,25 @@ JSON Web Algorithms (JWA) - collectively can be used to encrypt and/or sign
 content using a variety of algorithms.")
     (license license:expat)))
 
+(define-public python-jwcrypto
+  (package
+    (name "python-jwcrypto")
+    (version "1.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "jwcrypto" version))
+              (sha256
+               (base32
+                "138bh6x1yy0qpk63bxa7mxnd97gfdm1fkpwm8wrdz3g3z0fca79c"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-cryptography python-deprecated))
+    (home-page "https://github.com/latchset/jwcrypto")
+    (synopsis "Implementation of JOSE Web standards")
+    (description
+     "WCrypto is an implementation of the @dfn{Javascript Object Signing and
+Encryption} (JOSE) Web Standards.")
+    (license license:lgpl3+)))
+
 (define-public python-pyscss
   (package
     (name "python-pyscss")