summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-06 01:00:38 +0200
committerMarius Bakke <marius@gnu.org>2021-05-06 19:10:04 +0200
commitd51daf25c4210bdfe8e4d9db096bb8ccf088d3b4 (patch)
tree0ba4df9a03d4e4f2638a4b0a845d1bc506ae4277 /gnu/packages/python-web.scm
parentce7b202f9b157c173cb9c2ab8d7a4b2d4a17496a (diff)
downloadguix-d51daf25c4210bdfe8e4d9db096bb8ccf088d3b4.tar.gz
gnu: gunicorn: Respect '--without-tests'.
* gnu/packages/python-web.scm (gunicorn)[arguments]: Only run tests when
TESTS? is #true.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f13fb5b5c2..8b6b667c3f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016, 2017, 2020 Julien Lepiller <julien@lepiller.eu>
@@ -4708,10 +4708,13 @@ event loop.  It is implemented in Cython and uses libuv under the hood.")
              (delete-file "docs/build/texinfo/Gunicorn.texi")
              #t))
          (replace 'check
-           (lambda _
-             (setenv "PYTHONPATH"
-                     (string-append ".:" (getenv "PYTHONPATH")))
-             (invoke "pytest")))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (if tests?
+                 (begin
+                   (setenv "PYTHONPATH"
+                           (string-append ".:" (getenv "PYTHONPATH")))
+                   (invoke "pytest" "-vv"))
+                 (format #t "test suite not run~%"))))
          (add-after 'install 'install-doc
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((doc (string-append (assoc-ref outputs "doc")