summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-21 23:32:56 +0200
committerMarius Bakke <marius@gnu.org>2022-06-21 23:53:40 +0200
commitea8a7e824489112b96a0247d2c3728eca918a202 (patch)
tree9bd9defe4afddffd81d6e0207050d33a14fc0187 /gnu/packages/python-web.scm
parent964731ca524dd03a7a175f262a47a61e924a8cf6 (diff)
downloadguix-ea8a7e824489112b96a0247d2c3728eca918a202.tar.gz
gnu: python-databricks-cli: Update to 0.17.0.
* gnu/packages/python-web.scm (python-databricks-cli): Update to 0.17.0.
[arguments]: Enable previously failing test.
[propagated-inputs]: Remove PYTHON-CONFIGPARSER.  Add PYTHON-PYJWT.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b4500c6d2f..cbc2d843ea 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1808,7 +1808,7 @@ another XPath engine to find the matching elements in an XML or HTML document.")
 (define-public python-databricks-cli
   (package
     (name "python-databricks-cli")
-    (version "0.14.1")
+    (version "0.17.0")
     (home-page "https://github.com/databricks/databricks-cli")
     (source (origin
               (method git-fetch)
@@ -1816,21 +1816,25 @@ another XPath engine to find the matching elements in an XML or HTML document.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "03w19rzh72jll9phai23wp0c2mlv39qsrv50mhckziy39z60yxh8"))))
+                "1qwbxnx64kw7lrzlyx3hfbnjxpc19cqvvj0gcrkqpyjsgd08vja0"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
+     '(#:phases (modify-phases %standard-phases
                   (replace 'check
                     (lambda _
-                      (invoke "pytest" "tests" "-vv"
-                              ;; XXX: This fails with newer Pytest
-                              ;; (upstream uses Pytest 3..).
-                              "-k" "not test_get_request_with_list"))))))
+                      (invoke "pytest" "tests" "-vv"))))))
     (native-inputs
-     (list ;; For tests.
-           python-decorator python-mock python-pytest python-requests-mock))
+     ;; For tests.
+     (list python-decorator
+           python-mock
+           python-pytest
+           python-requests-mock))
     (propagated-inputs
-     (list python-click python-configparser python-requests python-six
+     (list python-click
+           python-oauthlib
+           python-pyjwt
+           python-requests
+           python-six
            python-tabulate))
     (synopsis "Command line interface for Databricks")
     (description