summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-14 11:59:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:23 +0300
commit071ee5856d00e22ea9e289e4a7cebe80a7871b06 (patch)
treee619ad75e770a0eb988162b68f8b2399432b1079 /gnu/packages/python-xyz.scm
parent339be9dad527bb0805e35dc1816cf373d445ed91 (diff)
downloadguix-071ee5856d00e22ea9e289e4a7cebe80a7871b06.tar.gz
gnu: python-blosc: Build with packaged blosc.
* gnu/packages/python-xyz.scm (python-blosc)[source]: Add snippet to
remove bundled sources.
[arguments]: Add a custom phase to set location of blosc.
[inputs]: Add c-blosc.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8cacdd5796..3be2d0dae5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25237,13 +25237,23 @@ they use the same path.")
        (uri (pypi-uri "blosc" version))
        (sha256
         (base32
-         "1cm91c6r431yla2mbs4895bgiianjf30dfz14vvv99dslygd65jw"))))
+         "1cm91c6r431yla2mbs4895bgiianjf30dfz14vvv99dslygd65jw"))
+       (snippet
+        #~(begin (use-modules (guix build utils))
+                 (delete-file-recursively "c-blosc")))))
     (build-system python-build-system)
     ;; FIXME: all tests pass, but then this error is printed:
     ;; TypeError: calling <function run at 0x7ffff2568d90> returned None, not a test
-    (arguments '(#:tests? #f))
+    (arguments
+     (list #:tests? #f
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'find-blosc
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (setenv "BLOSC_DIR" #$(this-package-input "c-blosc")))))))
     (propagated-inputs
      (list python-numpy))
+    (inputs (list c-blosc))
     (home-page "https://github.com/blosc/python-blosc")
     (synopsis "Python wrapper for the Blosc data compressor library")
     (description "Blosc is a high performance compressor optimized for binary