summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-16 14:17:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-16 14:17:48 +0100
commit08447ab7cdb4031d7e41870176e375911f4a0917 (patch)
tree1b119799018174ab1df4e2d71d7f7f6e88b1e7b2 /gnu/packages/python-xyz.scm
parentfa0a18522d5c382f82a391e2eca3c1ca48b60834 (diff)
downloadguix-08447ab7cdb4031d7e41870176e375911f4a0917.tar.gz
gnu: Add python-toposort.
* gnu/packages/python-xyz.scm (python-toposort): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ca00a8dc97..0c865dff33 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8029,6 +8029,25 @@ generate MPS or LP files and call GLPK, COIN CLP/CBC, CPLEX, and GUROBI to
 solve linear problems.")
     (license license:expat)))
 
+(define-public python-toposort
+  (package
+    (name "python-toposort")
+    (version "1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "toposort" version))
+       (sha256
+        (base32
+         "1b2hppzjg3p006qya3yfdnp76dwq8frl97lypdam0kw4xxb8yhm7"))))
+    (build-system python-build-system)
+    (home-page "https://gitlab.com/ericvsmith/toposort")
+    (synopsis "Topological sort algorithm")
+    (description
+     "This package provides an implementation of a topological sort
+algorithm.")
+    (license license:asl2.0)))
+
 (define-public snakemake
   (package
     (name "snakemake")