summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-12-29 17:26:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-12-29 17:26:17 +0100
commit375200111db1c90dcb3cd179609f0aab96360bed (patch)
treeb8043dd368f36e7e05ff7864dc830a54ed944411 /gnu/packages/python-xyz.scm
parent4d8b93e865ba71d2baa606d11529c3ecb5f14aea (diff)
downloadguix-375200111db1c90dcb3cd179609f0aab96360bed.tar.gz
gnu: python-dm-tree: Fix build.
* gnu/packages/python-xyz.scm (python-dm-tree)[arguments]: Drop
--whole-archive linker arguments because with them symbols provided by
libabsl_hash.a would not be found.

Change-Id: Id9ea0e233dc9a1cc76c88c08314803671e4810f9
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 0 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac82b4893..2afce6c667 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5935,7 +5935,6 @@ flexibility and power of the Python language.")
                       (string-append "-Wl," "-rpath=" python "/lib")
                       "-fno-semantic-interposition"
                       "build/temp/tree/tree.o"
-                      "-Wl,--whole-archive"
                       "-L" (string-append python "/lib")
                       (string-append abseil-cpp "/lib/libabsl_int128.a")
                       (string-append abseil-cpp "/lib/libabsl_raw_hash_set.a")
@@ -5943,7 +5942,6 @@ flexibility and power of the Python language.")
                       (string-append abseil-cpp "/lib/libabsl_strings.a")
                       (string-append abseil-cpp "/lib/libabsl_strings_internal.a")
                       (string-append abseil-cpp "/lib/libabsl_throw_delegate.a")
-                      "-Wl,--no-whole-archive"
                       "-o" "build/lib/tree/_tree.so")))))))
     (home-page "https://github.com/deepmind/tree")
     (synopsis "Work with nested data structures in Python")