summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-23 20:26:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:15 +0200
commit536228e65e8b4b0d35038188c5d4fefafe0af579 (patch)
treeab42574281b2ffd0ea8534aa572224aaea1ae91c /gnu/packages/python-xyz.scm
parent749cb3c5202cb90fde0d229483a24d00e3a67136 (diff)
downloadguix-536228e65e8b4b0d35038188c5d4fefafe0af579.tar.gz
gnu: python-pooch: Update to 1.8.1.
* gnu/packages/python-xyz.scm (python-pooch): Update to 1.8.1.
[arguments]: Enable tests, but not all of them.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add python-pytest and python-setuptools-scm.
[propagated-inputs]: Add python-platformdirs; remove python-appdirs and
python-packaging.

Change-Id: I3a0f73db5c0d78c9cee24c73402e9b1e34e26b4a
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm46
1 files changed, 40 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7e5ec06bab..80ec3c9d0a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26833,18 +26833,52 @@ inferring type information using compile-time introspection.")
 (define-public python-pooch
   (package
     (name "python-pooch")
-    (version "1.3.0")
+    (version "1.8.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pooch" version))
        (sha256
-        (base32 "1618adsg9r8fsv422sv35z1i723q3a1iir5v7dv2sklh4pl4im1h"))))
-    (build-system python-build-system)
+        (base32 "0w32fhfp67k0ip0gxjpw8kxdx9ghybxmqkv9sbwy99nrgl4n7vr7"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:tests? #f)) ;requires online data
-    (propagated-inputs
-     (list python-appdirs python-packaging python-requests))
+     (list
+      #:test-flags
+      '(list "-k"
+             (string-append
+              ;; We don't have the test archives
+              "not test_decompress"
+              " and not test_multiple_unpacking"
+              " and not test_unpack_members_with_leading_dot"
+              " and not test_unpacking"
+              " and not test_unpacking_members_then_no_members"
+              " and not test_unpacking_wrong_members_then_no_members"
+              ;; These all require access to the internet
+              " and not test_check_availability"
+              " and not test_check_availability_invalid_downloader"
+              " and not test_check_availability_on_ftp"
+              " and not test_create_and_fetch"
+              " and not test_downloader_arbitrary_progressbar"
+              " and not test_fetch_with_downloader"
+              " and not test_figshare_data_repository_versions"
+              " and not test_load_registry_from_doi"
+              " and not test_pooch_corrupted"
+              " and not test_pooch_custom_url"
+              " and not test_pooch_download"
+              " and not test_pooch_download_retry"
+              " and not test_pooch_download_retry_fails_eventually"
+              " and not test_pooch_download_retry_off_by_default"
+              " and not test_pooch_logging_level"
+              " and not test_pooch_update"
+              " and not test_retrieve"
+              " and not test_retrieve_default_path"
+              " and not test_retrieve_fname"
+              " and not test_stream_download")
+             "--ignore=pooch/tests/test_downloaders.py")))
+    (propagated-inputs
+     (list python-packaging python-platformdirs python-requests))
+    (native-inputs
+     (list python-pytest python-setuptools-scm))
     (home-page "https://github.com/fatiando/pooch")
     (synopsis "Manage your Python library's sample data files")
     (description