summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-11 15:36:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:37 +0100
commit53c65baa3d4590d78c7660369bac0e69d3804503 (patch)
tree3e74ebacdcdab017372878ff363ef223d2ebf2bc /gnu/packages/python-xyz.scm
parente31e5928ae92652be96f062a3dd785fe32d159a6 (diff)
downloadguix-53c65baa3d4590d78c7660369bac0e69d3804503.tar.gz
gnu: python-dask: Propagate click.
* gnu/packages/python-xyz.scm (python-dask)[native-inputs]: Move python-click
from here...
[propagated-inputs]: ...to here.

Change-Id: I1a1617d9cb00268d9fc26f4fe6c9ecc6d0a2e375
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 095e74c844..a806166569 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27053,7 +27053,8 @@ parentdir_prefix = dask-
           (add-before 'check 'pre-check
             (lambda _ (chdir "/tmp"))))))
     (propagated-inputs
-     (list python-cloudpickle
+     (list python-click ;needed at runtime
+           python-cloudpickle
            python-fsspec
            python-importlib-metadata ;needed at runtime for dask/_compatibility.py
            python-numpy
@@ -27063,8 +27064,7 @@ parentdir_prefix = dask-
            python-toolz
            python-pyyaml))
     (native-inputs
-     (list python-click
-           python-importlib-metadata
+     (list python-importlib-metadata
            python-pytest python-pytest-runner python-pytest-rerunfailures
            python-versioneer))
     (home-page "https://github.com/dask/dask/")