summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 16:05:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 17:48:05 +0300
commit5b6ac91ee4cd44df599f1e55156aa5e362da6d66 (patch)
tree42bdf9429cd8169c79d9317867e9038a2a806576 /gnu/packages/python-xyz.scm
parente22145ed3586984b13381c590e6c8c8c46b479bf (diff)
downloadguix-5b6ac91ee4cd44df599f1e55156aa5e362da6d66.tar.gz
gnu: Remove python-setuptools-scm/next.
* gnu/packages/python-xyz.scm (python-setuptools-scm/next): Remove
variable.
(python-pikepdf) [native-inputs]: Swap for python-setuptools-scm.
* gnu/packages/python-compression.scm (python-multivolumefile,
python-bcj-cffi, python-ppmd-cffi, python-p77zr)[native-inputs]: Same.
* gnu/packages/pep.scm (python-pep-adapter)[native-inputs]: Same.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 417630ad74..2da0471aa5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6338,7 +6338,7 @@ the OleFileIO module from PIL, the Python Image Library.")
     (native-inputs
      `(("pybind11" ,pybind11)
        ("python-setuptools" ,python-setuptools)
-       ("python-setuptools-scm" ,python-setuptools-scm/next)
+       ("python-setuptools-scm" ,python-setuptools-scm)
        ("python-setuptools-scm-git-archive" ,python-setuptools-scm-git-archive)
        ("python-toml" ,python-toml)
        ("python-wheel" ,python-wheel)))
@@ -7277,18 +7277,6 @@ child application and control it as if a human were typing commands.")
 them as the version argument or in a SCM managed file.")
     (license license:expat)))
 
-;; TODO: Merge with 'python-setuptools-scm' on the next rebuild cycle.
-(define-public python-setuptools-scm/next
-  (package
-    (inherit python-setuptools-scm)
-    (version "5.0.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "setuptools_scm" version))
-       (sha256
-        (base32 "0ahlrxxkx2xhmxskx57gc96w3bdndflxx30304ihvm7ds136nny8"))))))
-
 (define-public python2-setuptools-scm
   (package-with-python2 python-setuptools-scm))