summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-23 23:13:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-23 23:15:55 +0200
commit6bd9e0d50197cf08d2456d0c93b4711ed588622c (patch)
tree3e9b69a04aa5aee912f5a41e3275e2b2d39ee072 /gnu/packages/python-xyz.scm
parent09f527827a544f8ea3f1b7d0326d4febffdbaf4b (diff)
downloadguix-6bd9e0d50197cf08d2456d0c93b4711ed588622c.tar.gz
gnu: Add python-lfdfiles.
* gnu/packages/python-xyz.scm (python-lfdfiles): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a728494433..7eee3b6888 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5368,6 +5368,30 @@ NIH, ImageJ, MicroManager, MD GEL, and FluoView files.  It also lets you write
 numpy arrays to TIFF, BigTIFF, and ImageJ hyperstack compatible files.")
     (license license:bsd-3)))
 
+(define-public python-lfdfiles
+  (package
+    (name "python-lfdfiles")
+    (version "2020.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "lfdfiles" version))
+       (sha256
+        (base32
+         "1n9bkfn4vxl0lbhzd0m35lq86ayx5fwcj3ghpfl2vbjbsnfp3h47"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-click" ,python-click)
+       ("python-numpy" ,python-numpy)
+       ("python-tifffile" ,python-tifffile)))
+    (home-page "https://www.lfd.uci.edu/~gohlke/")
+    (synopsis "Work with LFD data files")
+    (description
+     "Lfdfiles is a Python library and console script for reading, writing,
+converting, and viewing many of the proprietary file formats used to store
+experimental data and metadata at the Laboratory for Fluorescence Dynamics.")
+    (license license:bsd-3)))
+
 (define-public python-pycparser
   (package
     (name "python-pycparser")