summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-26 22:54:04 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 00:33:33 +0100
commit7781bdf4b50930823454354e035231d816446048 (patch)
treefad880c974d21fdd5127d9301bdf00487df1c638 /gnu/packages/python-xyz.scm
parente2ccfea68d0424086794286198aa7f5c5b38ad97 (diff)
downloadguix-7781bdf4b50930823454354e035231d816446048.tar.gz
gnu: python-click-didyoumean: Enable tests.
* gnu/packages/python-xyz.scm (python-click-didyoumean): Enable tests.
[source]: Swap to git checkout containing tests.
[native-inputs]: Add python-pytest.

Change-Id: I741e52c92c1c1b5ccde557061a8be0010974610f
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 48204523db..ae8501d43e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11018,15 +11018,16 @@ your favourite programs.")
     (version "0.3.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "click_didyoumean" version))
+       (method git-fetch)               ;no tests in PyPI archive
+       (uri (git-reference
+             (url "https://github.com/click-contrib/click-didyoumean")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0qx4npxxgj87zk5hkah5ijrc76ba7ymdd6r7na5fyr5y1pzzv0jg"))))
+        (base32 "1byfqs3m87zfpvssm1al9dvq94gjd0iddpwrzk6205n18wjsphqb"))))
     (build-system pyproject-build-system)
-    (arguments
-     `(#:tests? #f))              ; no tests in PyPI and no setup.py in github
     (native-inputs
-     (list python-poetry-core))
+     (list python-poetry-core python-pytest))
     (propagated-inputs
      (list python-click))
     (home-page "https://github.com/timofurrer/click-didyoumean")