summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-26 21:28:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-26 21:33:02 +0200
commit95fdd862d0638ab176287d62b91e5c7fd30bc4b7 (patch)
tree9608df3ddcf666cebeaf5fe6c0b9a98fe11a907e /gnu/packages/python-xyz.scm
parentd12ad4105aaff0cbb2445a302af9de1e5af7ae13 (diff)
downloadguix-95fdd862d0638ab176287d62b91e5c7fd30bc4b7.tar.gz
gnu: python-dill: Update to 0.3.6.
* gnu/packages/python-xyz.scm (python-dill): Update to 0.3.6.
[build-system]: Use pyproject-build-system.
[arguments]: Run tests conditionally; drop trailing #T from build phase.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f57880ce2..badbe34f80 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23954,22 +23954,22 @@ object-oriented library such as @code{scikit-learn}.")
 (define-public python-dill
   (package
     (name "python-dill")
-    (version "0.3.5.1")
+    (version "0.3.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "dill" version))
        (sha256
-        (base32 "11lc40x37cx2i8qqbc5qklifm65dyjl6prrqsycybvpixzrl2pnp"))))
-    (build-system python-build-system)
+        (base32 "0wr37zwyiprrv29jcc1hl5cla72faiwfs0mhvbxxhmkqd3rmbnz5"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (with-directory-excursion "/tmp"
-               (invoke "nosetests" "-v"))
-             #t)))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (with-directory-excursion "/tmp"
+                 (invoke "nosetests" "-v"))))))))
     (native-inputs
      (list python-nose))
     (home-page "https://pypi.org/project/dill/")