summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-23 18:02:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-23 23:15:54 +0200
commit978d11f96e6ad9818dd005f8279f41a67be69935 (patch)
tree515fd827026dea6990365bfdfee15054f214f3ee /gnu/packages/python-xyz.scm
parent5db8ba1f49f207b2f6c537126f58fbc169d5a8a4 (diff)
downloadguix-978d11f96e6ad9818dd005f8279f41a67be69935.tar.gz
gnu: Add python-roifile.
* gnu/packages/python-xyz.scm (python-roifile): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 08fbec30da..9ab3323e5f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5320,6 +5320,28 @@ a general image processing tool.")
 (define-public python2-pillow
   (package-with-python2 python-pillow))
 
+(define-public python-roifile
+  (package
+    (name "python-roifile")
+    (version "2020.5.28")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "roifile" version))
+        (sha256
+          (base32
+            "1vwbwfsw745gyqymff6dllc5zqjsgqmxaw245sw4an6yw9rcbzc0"))))
+    (build-system python-build-system)
+    (arguments `(#:tests? #f)) ; there are none
+    (propagated-inputs
+      `(("python-numpy" ,python-numpy)))
+    (home-page "https://www.lfd.uci.edu/~gohlke/")
+    (synopsis "Read and write ImageJ ROI format")
+    (description "Roifile is a Python library to read, write, create, and plot
+ImageJ ROIs, an undocumented and ImageJ application specific format to store
+regions of interest, geometric shapes, paths, text, etc for image overlays.")
+    (license license:bsd-3)))
+
 (define-public python-pycparser
   (package
     (name "python-pycparser")