summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-21 12:39:57 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:21 +0800
commita392ec814f44578cf231fb9f1880a663820e0f5c (patch)
tree98c19adfcd7e55db8edef2679940b73fc276dcd1 /gnu/packages/python-xyz.scm
parent767b8586beea7d792e79daf434a76a5153fec881 (diff)
downloadguix-a392ec814f44578cf231fb9f1880a663820e0f5c.tar.gz
gnu: python-txaio: Update to 23.1.1.
* gnu/packages/python-xyz.scm (python-txaio): Update to 23.1.1.
[build-system]: Change to PYPROJECT-BUILD-SYSTEM.
[propagated-inputs]: Remove.
[native-inputs]: Add PYTHON-PYTEST and PYTHON-TWISTED.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d569e334d6..48b61a7e0e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26504,17 +26504,17 @@ and dates in \"human readable\" forms.  For example, it would display
 (define-public python-txaio
   (package
     (name "python-txaio")
-    (version "18.8.1")
+    (version "23.1.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "txaio" version))
         (sha256
          (base32
-          "1zmpdph6zddgrnkkcykh6qk5s46l7s5mzfqrh82m4b5iffn61qv7"))))
-    (build-system python-build-system)
-    (propagated-inputs
-     (list python-twisted python-six))
+          "017p9x0bssf7g9slmf30ddh1baawsmxas4nivx334pkfjxp23agr"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-pytest python-twisted))
     (home-page "https://github.com/crossbario/txaio")
     (synopsis "Compatibility layer between Python asyncio and Twisted")
     (description "Txaio provides a compatibility layer between the Python